Building Wayland on Ubuntu

Simos Xenitellis simos.lists at
Wed Oct 10 09:39:48 PDT 2012

On Wed, Oct 10, 2012 at 7:09 PM, 김은철 <chulspro at> wrote:
> Hi I am trying to build Wayland on Ubuntu.
> The problem is that now I get this error during build.
> - Requested 'xcb-glx >= 1.8.1' but version of XCB GLX is 1.5
> I am trying to download package using 'sudo apt-get install libxcb-glx0'
> but I got the message 'already newest'
> How can i fix this problem ?

You can check the available versions with

$ apt-cache policy libxcb-glx0

Ubuntu 12.04 has an older version of the library. However, on Ubuntu
12.10, it is

$ apt-cache policy libxcb-glx0
  Installed: 1.8.1-1ubuntu1
  Candidate: 1.8.1-1ubuntu1
  Version table:
 *** 1.8.1-1ubuntu1 0
        500 quantal/main amd64 Packages
        100 /var/lib/dpkg/status
$ _

which means that if you upgrade to 12.10, you will get the latest
version of the library.
Otherwise, you would need to install it manually.


More information about the wayland-devel mailing list