[PATCH 01/16] xdg_shell: Adding a new shell protocol.
spitzak at gmail.com
Sun Dec 1 11:45:35 PST 2013
On 11/29/2013 02:43 PM, Kristian Høgsberg wrote:
> - set_transient_for is not a great name. I know it comes from ICCCM,
> but I wonder if we can find a better name. If it's just stacking,
> then maybe just set_aboe?
How about "parent"? Though I guess "above" is acceptable...
Certainly the word "transient" is misleading. There is nothing transient
about the window, it can stay up longer than the parent.
> - not sure configure needs the edges flag anymore, in the cases where
> the server requests a change to the surface size, the server
> typically also knows where the window should go.
Clients showing a large scrolling canvas may want to react to resizes
such that the location of the canvas does not change on the output,
instead the portion next to the resizing corner is exposed/hidden. This
requires the client to know what edges are being moved.
> set(MAXIMIZED)+set(FULLSCREEN) will have the intended effect
> (ignore that MAXIMIZED and FULLSCREEN doesn't make sense).
Sure it makes sense. It indicates that unset(FULLSCREEN) will put it
into MAXIMIZED state. If the MAXIMIZED is turned off then
unset(FULLSCREEN) will put it into normal state.
More information about the wayland-devel