Arrgggh Wayland is not compiling again (xcb-composite)

Bill Spitzak spitzak at
Sun Dec 8 23:40:55 PST 2013

Thanks I got it to work.

Two mistakes I made:

1. I clicked on the wrong package and installed the i386 one rather than 
the x86_64 one.

2. When is run it copies the current value of 
$PKG_CONFIG_PATH to Thus my changes to this variable were 
being ignored each time I tried to run configure, yet annoyingly when I 
tried to duplicate the commands it was doing it worked.

On 12/08/2013 07:58 AM, Emilio Pozuelo Monfort wrote:
> On 08/12/13 16:48, Bill Spitzak wrote:
>> Make of weston is not working:
>> ~/swdevl/wayland/weston$ make > /dev/nullconfigure: error: Package requirements
>> (xcb xcb-xfixes xcb-composite xcursor cairo-xcb) were not met:
>> No package 'xcb-composite' found
>> I have the .pc file:
>> ls /usr/lib/i386-linux-gnu/pkgconfig
>> pthread-stubs.pc  xcb-composite.pc  xcb-render.pc  xcb-xfixes.pc
>> xau.pc            xcb.pc            xcb-shape.pc   xdmcp.pc
>> And that directory is on the $PKG_CONFIG_PATH
>> I also note that it seems to have found the xcb-fixes.pc in the same directory.
>> Any idea how to fix this?
> It may be that any of the .pc files needed by xcb-composite is missing, which
> would be a packaging bug. Check config.log or the output of `pkg-config --libs
> xcb-composite'.
>> Also it may be a dumb question, but why is weston depending on xcb-composite (or
>> any of xcb at all)?
> Seems to be required for xwayland which you can disable with --disable-xwayland.
> I don't know what it is needed for.
> Emilio

More information about the wayland-devel mailing list