[PATCH 0/5] Input method support cleanup

Yichao Yu yyc1992 at gmail.com
Thu Jan 31 07:38:47 PST 2013


On Thu, Jan 31, 2013 at 9:52 AM, Jan Arne Petersen
<jpetersen at openismus.com> wrote:
> From: Jan Arne Petersen <jpetersen at openismus.com>
>
> Another series of input method support patches. Mostly some
> cleanups in the protocol:
>
> * Remove some unused requests events (set_preedit etc)
>
> * Add a commit request to allow to batch different state
>   changes on application side together. That needs some more
>   documentation (also how it works in the other direction on
>   preedit_string and commit_string events).
>

Does it mean asking the input method to commit what it have now?

> * Add show/hide input panel requests to allow not always shwoing
>   input panels when activated (for example requiring an extra touch).

Is this a per-text_model state and will it be remembered after the
text_model is reset? What's the difference between not activating a
text_model and not showing the input panel? And what about the
proposed input overlay window? That's something the client should
never ever want to hide.

I also think the input method should have better knowledge what is the
source of input and that's where the "extra touch" should go. If a
virtual keyboard is in used, it may make sense not showing it whenever
a text_model is activated but that won't make much sense for a real
keyboard input. Isn't it enough to letting the input method showing a
small [show keyboard] button set as following the cursor which will
turn on/off the keyboard with your "extra touch". In this way, any
clients can benefit from it and the input method can even decide to
remember the state when necessary.

>
> * Rename set_micro_focus to set_cursor_rectangle to make more
>   clear what the requests does.
>
> * Split out the cursor position change from the commit_string into
>   an own event (and also allow to change the anchor position).
>
> Jan Arne Petersen (5):
>   text: Remove unused requests/events
>   text: Add commit request
>   text: Add show/hide_input_panel requests
>   text: Rename set_micro_focus request
>   text: Split out cursor_position
>
>  clients/editor.c           | 103 ++++++++++++++++++++++++++++++---------------
>  clients/keyboard.c         |  41 ++++++++++++------
>  clients/weston-simple-im.c |  27 +++++++++---
>  protocol/input-method.xml  |   7 ++-
>  protocol/text.xml          |  34 ++++++++++++---
>  src/shell.c                |   3 ++
>  src/text-backend.c         |  75 +++++++++++++++++++++++++++------
>  7 files changed, 217 insertions(+), 73 deletions(-)
>
> --
> 1.8.1
>
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/wayland-devel


More information about the wayland-devel mailing list