Simplify a function
Dennis Lan (dlan)
dennis.yxun at gmail.com
Wed Jul 24 19:47:48 PDT 2013
On Thu, Jul 25, 2013 at 6:51 AM, Jiergir Ogoerg <f35f22fan at gmail.com> wrote:
> Hi,
> I think in wayland-client.c the function
> wl_display_dispatch_queue_pending(...)
> could be simplified
> from this:
> pthread_mutex_lock(&display->mutex);
> if (dispatch_queue(display, queue) == -1)
> goto err_unlock;
> pthread_mutex_unlock(&display->mutex);
> return 0;
> err_unlock:
> pthread_mutex_unlock(&display->mutex);
> return -1;
>
> to this:
> int ret;
> pthread_mutex_lock(&display->mutex);
> ret = dispatch_queue(display, queue);
> pthread_mutex_unlock(&display->mutex);
> return (ret == -1) ? -1 : 0;
>
>
>
> Just my 0.02$
>
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/wayland-devel
>
Hi Jiergir:
I think this is a slightly better improvement, more readable
Dennis Lan (dlan)
More information about the wayland-devel
mailing list