[PATCH libinput 4/5] touchpad: rename scroll.state to scroll.edge_state

Peter Hutterer peter.hutterer at who-t.net
Thu Dec 18 15:24:53 PST 2014


In preparation for a twofinger_state field, to avoid confusion.

Signed-off-by: Peter Hutterer <peter.hutterer at who-t.net>
---
 src/evdev-mt-touchpad-edge-scroll.c | 6 +++---
 src/evdev-mt-touchpad.h             | 2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/src/evdev-mt-touchpad-edge-scroll.c b/src/evdev-mt-touchpad-edge-scroll.c
index 616080f..bc6831d 100644
--- a/src/evdev-mt-touchpad-edge-scroll.c
+++ b/src/evdev-mt-touchpad-edge-scroll.c
@@ -69,7 +69,7 @@ tp_edge_scroll_set_state(struct tp_dispatch *tp,
 {
 	libinput_timer_cancel(&t->scroll.timer);
 
-	t->scroll.state = state;
+	t->scroll.edge_state = state;
 
 	switch (state) {
 	case EDGE_SCROLL_TOUCH_STATE_NONE:
@@ -207,7 +207,7 @@ tp_edge_scroll_handle_event(struct tp_dispatch *tp,
 			    struct tp_touch *t,
 			    enum scroll_event event)
 {
-	switch (t->scroll.state) {
+	switch (t->scroll.edge_state) {
 	case EDGE_SCROLL_TOUCH_STATE_NONE:
 		tp_edge_scroll_handle_none(tp, t, event);
 		break;
@@ -374,5 +374,5 @@ tp_edge_scroll_stop_events(struct tp_dispatch *tp, uint64_t time)
 int
 tp_edge_scroll_touch_active(struct tp_dispatch *tp, struct tp_touch *t)
 {
-	return t->scroll.state == EDGE_SCROLL_TOUCH_STATE_AREA;
+	return t->scroll.edge_state == EDGE_SCROLL_TOUCH_STATE_AREA;
 }
diff --git a/src/evdev-mt-touchpad.h b/src/evdev-mt-touchpad.h
index 1450288..e284928 100644
--- a/src/evdev-mt-touchpad.h
+++ b/src/evdev-mt-touchpad.h
@@ -165,7 +165,7 @@ struct tp_touch {
 	} tap;
 
 	struct {
-		enum tp_edge_scroll_touch_state state;
+		enum tp_edge_scroll_touch_state edge_state;
 		uint32_t edge;
 		int direction;
 		double threshold;
-- 
2.1.0



More information about the wayland-devel mailing list