[PATCH 1/2 v2] version: Fix WESTON_VERSION_AT_LEAST macro

Bill Spitzak spitzak at gmail.com
Fri Jan 24 14:23:00 PST 2014


If a feature remains in N minor versions the programmer would have to 
put in N compatable-with macros to enable it. They would also have to 
update the code every time a new minor version comes out (or just 
predict a number of minor versions into the future and put in a bunch of 
calls to this).

An "at least" macro can cover the N minor versions with only two calls, 
one to check that it is at least the version the feature appeared in, 
and another to check it is not at least the version the feature 
disappeared in.

Please change AT_LEAST to work as people expect, and don't bother with 
this COMPATIBLE_WITH idea. At least rename it as "MAJOR_MINOR_EQUALS" or 
something clearly saying what it does.

On 01/24/2014 12:37 PM, Daniel Stone wrote:
> Hi,
> The macro should really be called WESTON_VERSION_COMPATIBLE_WITH() -
> it's done that way specifically to allow breaking API/ABI at least
> every minor release.




More information about the wayland-devel mailing list