[PATCH libinput 1/2] touchpad: drop the BOTTOM_TO_AREA state

Hans de Goede hdegoede at redhat.com
Wed Jul 2 01:38:44 PDT 2014


On 07/02/2014 08:49 AM, Peter Hutterer wrote:
> The original intention of this state was to prevent an accidental move out of
> the bottom software button to start moving the cursor. That ends up actually
> preventing a number of normal moves that start low enough. Simply drop the
> state.

Thanks for working on this.

> Signed-off-by: Peter Hutterer <peter.hutterer at who-t.net>
> ---
> Left the other timeouts in for now, half out of lazyness, half because the
> other timeouts don't bother me.

Ack, I think the timeouts may actually make sense for the top buttons case.

>  doc/touchpad-softbutton-state-machine.svg | 931 +++++++++++++-----------------
>  src/evdev-mt-touchpad-buttons.c           |  41 +-
>  src/evdev-mt-touchpad.h                   |   1 -
>  3 files changed, 402 insertions(+), 571 deletions(-)
> diff --git a/doc/touchpad-softbutton-state-machine.svg b/doc/touchpad-softbutton-state-machine.svg
> index 05254d0..5ca68b4 100644
> --- a/doc/touchpad-softbutton-state-machine.svg
> +++ b/doc/touchpad-softbutton-state-machine.svg


Note I've only looked at the updated state diagram for this review,
not at the code changes.

With the BOTTOM_TO_AREA state gone I see no reason have separate
BOTTOM_NEW and BOTTOM states. I think we should rename BOTTOM_NEW
to BOTTOM. This will nicely clean up the state diagram. Note we
need to keep the "finger in bottom, button != curr" state transition
which goes from BOTTOM_NEW to BOTTOM_NEW so as to re-trigger the
on-entry behavior when the finger moves from one button area
to another. With this change the "start enter time" should also
be removed from the on-entry actions.

Also there seems to be a leave timeout transition left over going
into the AREA state, coming from now where. That should be removed



More information about the wayland-devel mailing list