[PATCH libinput] tablet: Rename TILT_VERTICAL and TILT_HORIZONTAL to TILT_X and TILT_Y

Bill Spitzak spitzak at gmail.com
Thu Jul 10 11:40:23 PDT 2014



On 07/09/2014 10:29 PM, Peter Hutterer wrote:
> On Wed, Jul 09, 2014 at 01:14:48AM -0400, Stephen Chandler Paul wrote:
>> Since the orientation of the tablet can potentially change, this naming scheme
>> makes a lot more sense then VERTICAL and HORIZONTAL does since they don't
>> reflect the actual physical movement.

This looks backwards to me:

>>   	case ABS_TILT_X:
>> -		axis = LIBINPUT_TABLET_AXIS_TILT_HORIZONTAL;
>> +		axis = LIBINPUT_TABLET_AXIS_TILT_Y;
>>   		break;
>>   	case ABS_TILT_Y:
>> -		axis = LIBINPUT_TABLET_AXIS_TILT_VERTICAL;
>> +		axis = LIBINPUT_TABLET_AXIS_TILT_X;
>>   		break;
>>   	default:

I don't think you should reverse the meaning of the names fro whatever 
evcode is using.

I suppose "TILT_X" can either mean "tilt in a plane parallel to the x 
axis" or it can mean "tilt about the x axis". I think most people will 
assume the first meaning but I can imagine either one being used. But in 
any case two libraries should not disagree, right?



More information about the wayland-devel mailing list