peter.hutterer at who-t.net
Wed Jun 4 15:27:38 PDT 2014
On Thu, Jun 05, 2014 at 12:21:52AM +0200, Jonas Ådahl wrote:
> On Thu, Jun 05, 2014 at 07:45:00AM +1000, Peter Hutterer wrote:
> > On Wed, Jun 04, 2014 at 10:40:10PM +0200, Jonas Ådahl wrote:
> > > On Wed, Jun 04, 2014 at 12:54:58PM +1000, Peter Hutterer wrote:
> > > > On Tue, Jun 03, 2014 at 08:08:02PM -0400, Stephen Chandler Paul wrote:
> > > > > Button states are applicable to more then just the pointer, so having a
> > > > > non-generic name name for a generic enumerator value like
> > > > > libinput_pointer_button_state doesn't make sense. Changing it to something
> > > > > generic like libinput_button_state allows it to be reused by other devices that
> > > > > may potentially be added to libinput in the future.
> > > > >
> > > > > Signed-off-by: Stephen Chandler Paul <thatslyude at gmail.com>
> > > >
> > > > this looks good to me, and saves us from introducing a separate but same
> > > > enum for the tablet buttons.
> > >
> > > Looks good to me too, but would like to wait with pushing until I have
> > > patches to avoid breaking at least weston and GNOME builders.
> > can you take this one into your tree and push it together with the fixed ->
> > double changes? Then do a 0.3 release, that reduces the pain for everyone
> > involved.
> That has been my plan indeed. We could wait a short while with 0.3 and
> just bump the version to 0.2.99, if there are any other API breaks you
> can think of, otherwise a 0.3 sounds good.
I don't have any API _breaks_ coming up, just additions, so I'd be fine with
More information about the wayland-devel