[RFC PATCH libinput] Rename scroll_mode to scroll_method

Hans de Goede hdegoede at redhat.com
Wed Nov 19 01:48:06 PST 2014


On 11/19/2014 03:31 AM, Peter Hutterer wrote:
> Signed-off-by: Peter Hutterer <peter.hutterer at who-t.net>
> --- 
> would like to get some input from native english speakers here. I was
> writing hooks to use the new scroll method interface and for some reason
> scroll "mode" struck me as the wrong word, with "method" being more
> appropriate to describe how the scrolling is triggered. I didn't pick that
> up on reviewing, only when I started using the hooks.
> fwiw, the definitions of both words:
> mode
>         a way or manner in which something occurs or is experienced,
>         expressed, or done.
> method
>         a particular procedure for accomplishing or approaching something,
>         especially a systematic or established one.
> funnily enough 'mode' seems the correct word for natural scrolling, so you'd
> set a scroll method and have the natural scroll mode enabled/disabled. which
> sounds right to me but feels like it could be inconsistent too.
> and that's where I need input from someone who knows this stuff better than
> me...

I'm not attached to the mode name, method works for me too.



More information about the wayland-devel mailing list