[PATCH wayland] tests: rename NO_ASSERT_LEAK_CHECK
spitzak at gmail.com
Wed Nov 26 11:01:46 PST 2014
On 11/26/2014 06:25 AM, Marek Chalupa wrote:
> On 20 November 2014 at 23:59, Bryce Harrington <bryce at osg.samsung.com
> <mailto:bryce at osg.samsung.com>> wrote:
> On Wed, Nov 19, 2014 at 12:00:10PM +0100, Marek Chalupa wrote:
> > This env variable is used for turning off the leak checks in tests.
> > Rename it to WAYLAND_TESTS_NO_LEAK_CHECK, so that it is consistent
> > with WAYLAND_TESTS_NO_TIMEOUTS.
> Should these both be 'WAYLAND_TEST_'? In weston there is already a
> If WAYLAND_TESTS_* is better, then maybe WESTON_TEST_CLIENT_PATH should
> be changed for consistency.
The plural seems wrong to me. Calling them WAYLAND_TEST_* I think is
much more what I would expect. The reason is that this is not
controlling "tests" (a plural), but instead controlling "testing" (a
More information about the wayland-devel