[PATCH libinput 0/8] Add libinput_device_suspend() to disable devices

Hans de Goede hdegoede at redhat.com
Tue Oct 7 01:46:50 PDT 2014


On 10/06/2014 09:44 PM, Bill Spitzak wrote:
> On 10/06/2014 05:59 AM, Peter Hutterer wrote:
>>> FORCE_ENABLED - Bypass anything that makes the device stop reporting events.
>> why would you want that setting? if it's disabled when it shouldn't be then
>> this is a bug we need to fix.
> It is what you are calling "enabled".
> My complaint is that the setting everybody *should* use has the complicated name "disabled_on_external_mouse", while the seemingly obvious setting of "enabled" means that user preferences are being ignored.
> My proposal is to rename things like this:
> 1. Rename "enabled" to "force_enabled" or "enable_even_if_external_mouse", or *anything* that describes how it modifies the behavior of the driver from how the programmer of the driver intended.
> 2. Rename "disabled_on_external_mouse" to "enabled".

Erm, no just no, this will not help API users understand what the various
options actually do, oin the contrary this will only help to confuse users.

More over, in the future we may get disabled_on_lid_close and disabled_on_tablet_mode,
etc. The idea being that these are flags which can be or-ed together (using them
together with the unconditional disabled / enabled flags will lead to an EINVAL
error). What does enabled mean then? all of the flags ? If that is the case, then
the meaning of it will change as we add new flags, not good.



More information about the wayland-devel mailing list