[PATCH libinput v2 8/9] touchpad: Rename consumed to filter_motion

Hans de Goede hdegoede at redhat.com
Sun Sep 28 04:21:07 PDT 2014


This is what the return value in tp_tap_handle_state is called, and it better
reflects what the flag does.

Signed-off-by: Hans de Goede <hdegoede at redhat.com>
---
 src/evdev-mt-touchpad.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/src/evdev-mt-touchpad.c b/src/evdev-mt-touchpad.c
index a8d12e4..092e26f 100644
--- a/src/evdev-mt-touchpad.c
+++ b/src/evdev-mt-touchpad.c
@@ -527,7 +527,7 @@ tp_post_events(struct tp_dispatch *tp, uint64_t time)
 {
 	struct tp_touch *t = tp_current_touch(tp);
 	double dx, dy;
-	int consumed = 0;
+	int filter_motion = 0;
 
 	/* Only post (top) button events while suspended */
 	if (tp->device->suspended) {
@@ -535,10 +535,10 @@ tp_post_events(struct tp_dispatch *tp, uint64_t time)
 		return;
 	}
 
-	consumed |= tp_tap_handle_state(tp, time);
-	consumed |= tp_post_button_events(tp, time);
+	filter_motion |= tp_tap_handle_state(tp, time);
+	filter_motion |= tp_post_button_events(tp, time);
 
-	if (consumed) {
+	if (filter_motion) {
 		evdev_stop_scroll(tp->device, time);
 		return;
 	}
-- 
2.1.0



More information about the wayland-devel mailing list