How to match versions of wayland/weston/freerdp?

Manuel Bachmann manuel.bachmann at
Mon Apr 13 10:36:35 PDT 2015

Hi Marko,

You might have found that information in older threads, but FreeRDP commit
2604ff20bd12e810cfeed735b80dbe90020d781c works well for us starting from
Weston 1.5.0 (on x86/x86_64 at least, some people reported problems with


2015-03-13 21:54 GMT+01:00 Marko Moberg <marko.s.moberg at>:

> Hello there,
> I have a little question regarding Wayland/Weston and their compatibility
> with freeRdp.
> I am working on a fairly old Yocto branch ("dylan") but I need to enable
> support for Wayland/Weston with RDP. According to the info on the web, RDP
> support should be available from Wayland/Weston 1.1 onwards.
> I can get the v1.1 Wayland/Weston from "dora" branch but it seems that
> Yocto "dora" comes with a incompatible version of freeRDP (it contains
> freeRdp v1.0.2 whereas Weston seems to require 1.1.0 or newer). Problems in
> Weston compilation occur immediately when rdp protocol is enabled.
> Well, I also tried to update the freeRDP 1.1 to my environment but the
> rdp_compositor.c of Weston is still not matching the freeRDP
> implementation. However, I noticed that Weston 1.2 seems to have some
> changes that match with the rdp protocol api of FreeRdp 1.1 (changes like
> context_size -> ContextSize, stream_free -> Stream_Free etc.).
> Does anybody know which version are compatible with each other?
> There are some complex dependencies in our distro which makes it quite
> hard to work with the most up-to-date SW at this point so that's why I am
> trying to find the minimum set of changes to get the Weston + freeRDP
> running on old "dylan" based distro.
> regards,
> Marko
> marko.s.moberg at
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at


*Manuel BACHMANN Tizen Project VANNES-FR*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the wayland-devel mailing list