[PATCH] RDP compositor: fixes for multiple connections and mstsc

Hardening rdp.effort at gmail.com
Wed Feb 4 09:42:54 PST 2015

Le 02/02/2015 21:03, John Obaterspok a écrit :
> Hello,
> I had a bit problem to apply the patch. I tried both 1.6.0 and weston git. 
> Finally I went to patch the 1.6.0 version I have in Fedora 21.
> I needed to comment out the cmd->skipCompression = FALSE;

I have a patch for this.

> freerdp-devel-1.2.0-0.2.beta.1.fc21.x86_64
> #define FREERDP_VERSION_SUFFIX "beta1"
> #define FREERDP_API_VERSION "1.2"
> #define FREERDP_VERSION "1.2.0"
> #define FREERDP_VERSION_FULL "1.2.0-beta1"
> #define GIT_REVISION "n/a"
> Then I needed to comment out the below line which had undefined function
> for me:
> nsc_context_reset(peerCtx->nsc_context);
Hum I don't know what's wrong withe the version of FreeRdp shipped with
fedora 21, as nsc_context_reset() is there from a really long time. I'll
try to workaround that but without promise (got to install a fedora 21
to see what's going no). Using FreeRDP master could be a good option.

> I tried to run "weston -Brdp-backend.so" with these modifications.
> Weston started, I failed to connect (mstsc client just waited for ever),
> but no crash occured in weston.
Have you certificates configured ? any relevant logs ?


David FORT
website: http://www.hardening-consulting.com/

More information about the wayland-devel mailing list