[ANNOUNCE] libinput 0.11.0
Peter Hutterer
peter.hutterer at who-t.net
Sun Feb 22 16:59:09 PST 2015
A new release of libinput, 0.11.0, is now available.
This release is ABI-compatible with libinput 0.10, new functions have been
added.
A new function is available:
libinput_device_pointer_has_button()
this call deprecates
libinput_device_has_button()
and provides the same functionality. A simple search/replace is sufficient
to avoid the compiler warning.
The two new features added in this release are device groups and the use of
udev tagging for device identification.
Device groups are a labelling system to allow callers to identify which
libinput devices are part of the same physical device. All devices in the
same device group return the same opaque libinput_device_group object. Those
objects carry no other information otherwise. The set of new APIs
introduced:
libinput_device_get_device_group()
libinput_device_group_ref()
libinput_device_group_unref()
libinput_device_group_set_user_data()
libinput_device_group_get_user_data()
Prior to this release, libinput had its own logic for deciding whether a
device was a mouse, a touchpad, a tablet, etc. These rules were sometimes at
odds with the udev id_input builtin causing some misdetection. For this
release, we have switched to using ID_INPUT_* tags to determine the device
type. This enables local overrides as well where necessary (e.g. libwacom
tags all known tablets as ID_INPUT_TABLET). For more information, see:
http://wayland.freedesktop.org/libinput/doc/latest/udev_config.html
The full commit shortlog is below.
Benjamin Tissoires (2):
evdev: retrieve udev tags
Use LIBINPUT_DEVICE_GROUP from udev as group identifier
Marek Chalupa (1):
add simple symbols leak checker
Peter Hutterer (19):
Introduce device groups to group logical devices together
doc: document that we're ignoring position-less clicks
README: Add the libinput component to the bugzilla URL
evdev: switch to using udev's device tagging system
doc: add a dot graph for device groups and two missing @refs
evdev: add missing %s for accelerometer tagging
Add two missing @ref tags
Add libinput_device_pointer_has_button over the plain has_button
tools: print the device group in event-debug
Add udev bits to assign LIBINPUT_DEVICE_GROUP
evdev: check the first parent of the event node for ID_INPUT tags
Rename noaccel to unaccel for consistency
udev: fix a race condition if a device disappears before we get a handle
cosmetic: drop double empty lines
test: fix Coverity complaints
cosmetic: fix a whitespace issue
doc: add missing space
doc: document udev device tagging
configure.ac: libinput 0.11.0
git tag: 0.11.0
http://www.freedesktop.org/software/libinput/libinput-0.11.0.tar.xz
MD5: 59fef57c3a3151d6f4be539469d67e37 libinput-0.11.0.tar.xz
SHA1: 95d22be07f385c9c17a509e4d67bc5704274e227 libinput-0.11.0.tar.xz
SHA256: 927cd6792f95ea5e087448818cefe62c37fc5d76eed99b8c67fabee436bd0743 libinput-0.11.0.tar.xz
PGP: http://www.freedesktop.org/software/libinput/libinput-0.11.0.tar.xz.sig
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/wayland-devel/attachments/20150223/585f7f30/attachment.sig>
More information about the wayland-devel
mailing list