[PATCH weston] xwm: don't set inactive surfaces as top level
Bill Spitzak
spitzak at gmail.com
Mon Jan 19 17:57:43 PST 2015
On 01/12/2015 09:14 AM, Giulio Camuffo wrote:
> +static bool
> +weston_wm_window_inactive(struct weston_wm_window *window)
> +{
> + struct weston_wm *wm = window->wm;
> +
> + return window->type == wm->atom.net_wm_window_type_tooltip ||
> + window->type == wm->atom.net_wm_window_type_dropdown ||
> + window->type == wm->atom.net_wm_window_type_dnd ||
> + window->type == wm->atom.net_wm_window_type_combo ||
> + window->type == wm->atom.net_wm_window_type_popup;
> +}
I think maybe this should be called "window_type_inactive" because the
current name implies this is some kind of check for whether the window
is "currently inactive". Also is it necessary to namespace the static
function with "weston_wm_" prefix?
More information about the wayland-devel
mailing list