[ANNOUNCE] libinput 0.16.0
Peter Hutterer
peter.hutterer at who-t.net
Mon Jun 1 15:43:38 PDT 2015
A new release of libinput, 0.16.0, is now available.
No API changes or additions and much of the work has gone into the
test-suite.
There are still a couple of new features:
Touchpads with ABS_MT_DISTANCE such as the Chromebook Pixel are now
supported.
The tapping code now allows ending a tap-and-drag with an extra tap, i.e.
the sequence becomes:
tap, finger down, move .... move, finger up, tap
As soon as the final tap is detected, libinput sends the button release
event and ends the drag. This provides a more responsive interaction than
waiting for the timeout.
Also in the touchpad code: disable-while-typing has been added. While it is
currently switched on for all touchpads, we expect some fine-tuning over
time to detect erroneous touches better and through other means than a
simple timeout.
As usual, the git shortlog is below.
Benjamin Tissoires (3):
test: bcm5974: down should be marked as static
test: rename hover tests into semi_mt_hover
touchpad: add support for per-finger hovering information
Jan Alexander Steffens (heftig) (1):
Rename MODEL_SYSTEM76_CLEVO to MODEL_CLEVO_W740SU
Jon A. Cruz (3):
Add missing config.h includes
Add xasprintf to avoid use of undefined pointer values
test: address gcc warnings on potentially uninitialized variables.
Peter Hutterer (87):
test: move a comment to where it belongs
test: return the right value from open_restricted
doc: add a page about the test suite
filter: add Simon's copyright
test: litest_is_button_event should take an unsigned int
test: re-order the tests to have the likely ones to fail first
test: add litest_is_axis_event() helper
test: add litest_is_motion_event() helper
test: add litest_is_touch_event() helper function
test: add litest_is_keyboard_event() helper function
test: use litest_is_button_event() helper
tools: add middle button emulation to listed capabilities
test: add litest_add_ranged* functionality
test: switch the abs ranged tests over to real ranged tests
test: switch the touchpad multitap tests over to ranged tests
timer: fix coverity warning about unused return value
touchpad: switch from is_palm to an enum
touchpad: add timeout-based disable-while-typing
touchpad: use a two-stage timeout for disable-while-typing
doc: add some documentation for disable-while-typing
test: type-safe two ck_assert invocations
test: don't use enum values in ck_assert macros directly
test: cast to int before integer comparison
test: add a backtrace facility to litest
test: add pointer comparison macros
test: extract file:line from backtrace with addr2line
test: convert all helper functions to use the litest macros
test: drop unneeded includes
path: be more lenient waiting for udev to settle things
test: parse the LITEST_VERBOSE environment variable
test: add a note to one of the device tests
Allow disabling tapping on a device without tapping
Allow disabling of middle button emulation where it doesn't exist
doc: clarify a comment what a "no device" test case means
test: move opening { to next line
test: add missing linebreak in debug error message
evdev: log a bug if releasing a key fails, but don't loop forever
touchpad: rename all interface functions for clarity
evdev: move release_pressed_keys() up
evdev: add an interface hook to suspend a device
evdev: sync the initial x/y position for touchscreens
evdev: sync the initial state for absolute pointer devices
touchpad: sync the initial touch state
test: move main() into litest
test: move argument parsing into a separate function
test: add filtering to litest framework
test: add --filter-device argument
test: add --filter-group argument to match test groups (suites)
doc: drop leftovers of Check's selective test running
test: add missing filter for function names
test: fail if the filter leaves us with zero tests
test: fix --list for the tests
Add .vimdir for libinput-specific settings
Add a few more exclusions to .gitignore
test: move litest_log/vlog up outside of HAVE_LIBUNWIND
test: pclose the popened stream
test: fail if fgets() from addr2line returns NULL
test: fix coverity complaint about unbounded loop
Add streq() helper to use instead of strcmp() == 0
evdev: rename evdev_compare_syspath for clarity
test: add an extra loop for slow udev initialization
touchpad: move disable-while-typing into its own struct
touchpad: extend the key blacklist for disable-while-typing
touchpad: add helper function to get from tp to the libinput context
touchpad: only check keyboards for disable-while-typing
touchpad: be finer-grained about when to pair touchpads/keyboard for DWT
test: add disable-while-typing tests
touchpad: split disable-while-typing handling into a helper function
touchpad: add palm state debugging
touchpad: reset the touch state when edge scrolling is stopped
touchpad: don't enable edge palm detection on Wacom touchpads
touchpad: touches after the last key press can be released
touchpad: add missing break statement
Update Red Hat's copyright
doc: add a blurb about scroll sources to the scrolling docs
doc: add illustrations for clickfinger and software button behavior
doc: improve the T440 documentation a bit
README: spice up the readme a bit
test: don't abort if the device filter filtered all devices
tools: print symbolic key names too from event-debug
touchpad: check touchpad for basic features we expect
test: add another wait loop for udev
evdev: use the udev ID_INPUT_POINTINGSTICK property
COPYING: note that having linux/input.h in the tree does not make libinput GPL
README: add two diagrams to outline the stack
doc: add a FAQ page
configure.ac: libinput 0.16.0
Velimir Lisec (2):
touchpad: end tap-and-drag with an extra tap
test: add test cases for ending drag with a tap
git tag: 0.16.0
http://www.freedesktop.org/software/libinput/libinput-0.16.0.tar.xz
MD5: a5f5e1bb8eb2cd3bb9f5bd48f296def8 libinput-0.16.0.tar.xz
SHA1: 4b53842fbc38a41eddbf0246706cc4af90806cf3 libinput-0.16.0.tar.xz
SHA256: 4fde1b50431d8bd17b9c0a9624a57fd69eaebabe32ef684a83b9862a239d239b libinput-0.16.0.tar.xz
PGP: http://www.freedesktop.org/software/libinput/libinput-0.16.0.tar.xz.sig
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/wayland-devel/attachments/20150602/e7e01636/attachment.sig>
More information about the wayland-devel
mailing list