[PATCH weston 1/4] compositor-wayland: Change focus to a bool instead of an int
Daniel Stone
daniel at fooishbar.org
Fri Oct 9 09:41:35 PDT 2015
Hi,
On 9 October 2015 at 17:28, Derek Foreman <derekf at osg.samsung.com> wrote:
> diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c
> index 7b11ae4..dbbc1ad 100644
> --- a/src/compositor-wayland.c
> +++ b/src/compositor-wayland.c
> @@ -177,7 +177,7 @@ struct wayland_input {
> enum weston_key_state_update keyboard_state_update;
> uint32_t key_serial;
> uint32_t enter_serial;
> - int focus;
> + bool focus;
Bikeshed: has_focus. (That the other 'focus' variables actually refer
to outputs is confusing enough, to an extent ...)
Cheers,
Daniel
More information about the wayland-devel
mailing list