[PATCH weston v6 07/12] headless: port the headless backend to the new init api

Pekka Paalanen ppaalanen at gmail.com
Mon Apr 18 11:49:14 UTC 2016


On Sun, 17 Apr 2016 17:14:17 +0300
Giulio Camuffo <giuliocamuffo at gmail.com> wrote:

> Reviewed-by: Giulio Camuffo <giuliocamuffo at gmail.com>
> 
> 2016-04-16 6:28 GMT+03:00 Bryce Harrington <bryce at osg.samsung.com>:
> > From: Benoit Gschwind <gschwind at gnu-log.net>
> >
> > refactor configuration API of headless-backend
> >
> > Signed-off-by: Bryce Harrington <bryce at osg.samsung.com>
> > Reviewed-by: Pekka Paalanen <pekka.paalanen at collabora.co.uk>
> >
> > v6:
> >   - Define version number in the header
> >   - Don't use leading underscores in header guards
> >   - Add stub config_init_to_defaults()
> >   - Allocate config on stack
> >   - Drop unused display_name parameter
> >   - Add error message when config is invalid
> >   - Install compositor-headless.h and list it in headless-backend sources
> > v5:
> >   - Update to current trunk
> >   - Fixed typo 'struct weston_wayland_backend_config'
> >   - Dropped unused variables
> >   - Dropped weston_headless_backend_config_create() in favor of
> >     directly zalloc'ing the object
> >   - Dropped weston_headless_backend_load() in favor of the more
> >     generalized load_backend_new().
> >   - Dropped typedef from header
> >   - Restored use of 'backend_init' entry point
> >   - Backend_init() takes a base weston_backend_config object
> >   - Renamed 'param' to 'config' in a few places for consistency
> >   - Renamed 'headless_options' variable to 'options for consistency
> >   - Version the base struct
> >   - Free config on error
> >   - Don't free config during backend_init normal operations
> >   - Adjust header ordering
> >   - Make header guard naming consistent with other headers
> >   - Light reformatting for code style and consistency with other
> >     backend config patches
> >
> > Signed-off-by: Bryce Harrington <bryce at osg.samsung.com>
> > ---
> >  Makefile.am               |  3 ++
> >  src/compositor-headless.c | 74 +++++++++++++++++++++--------------------------
> >  src/compositor-headless.h | 53 +++++++++++++++++++++++++++++++++
> >  src/main.c                | 45 ++++++++++++++++++++++++++--
> >  4 files changed, 132 insertions(+), 43 deletions(-)
> >  create mode 100644 src/compositor-headless.h
> >

Hi,

since this patch was ready by both Giulio's and my opinion, I decided
to rebase it to apply upstream before the drm or x11 backend
conversions.

I also took the headless part of the patch "[PATCH weston v6 11/12]
Enforce destruction of all backend config objects after initialization"
and squashed it into this patch.

Pushed:
   20b66c3..3c53094  master -> master


Thanks,
pq
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 811 bytes
Desc: OpenPGP digital signature
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20160418/9563be3f/attachment.sig>


More information about the wayland-devel mailing list