Running cairo's tests on xwayland under weston

darxus at darxus at
Sat Aug 20 19:40:43 UTC 2016

I re-ran these cairo tests on SardemFF7's weston testing branch, in an
attempt to reduce variation, and got the same results.  Of the xcb-window
tests, 501 failed, 23 passed.  All xcb-window output appears to be entirely

Any ideas why?

< SardemFF7> Darxus:
< SardemFF7> use this branch, and launch "weston" 
< SardemFF7> Darxus: in .libs, and weston can find it (with "export WESTON_BUILD_DIR=$PWD")
< SardemFF7> it’ll have a black background, and the surface will be at (0,0) all the time
< SardemFF7> it’s a shell for tests, so surfaces cannot jump between runs

On 08/20, darxus at wrote:
> SardemFF7 suggested running cairo's make check against xwayland under
> weston, which sounded fun.  
> Cairo's tests have some difficulties, but this much passes normally:
> Doing the same on xwayland also passes, which is cool.  But testing against
> freshly generated references skips a lot of usefulness.
> Then I ran the tests on xwayland with the references generated with Xvfb
> (which is what cairo recommends).  Most of those passed, with the exception
> of tests for xcb-window output.  Most of them failed, all with blank output
> (all black).  It looks like all the xcb-window tests that passed may have
> been expected to have blank output. 
> Anybody have thoughts on why that output would be all black?  Or if it's a
> problem that should be fixed?  On the wayland or cairo side?
> (I ran weston with the -i0 command line argument to disable the screensaver
> / locking.  And I ran weston as an X client.)
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at

More information about the wayland-devel mailing list