[PATCH weston v2 1/8] Rename weston_compositor_xkb_init to weston_compositor_set_xkb_rule_names
sardemff7+wayland at sardemff7.net
Thu Jun 2 08:07:10 UTC 2016
On 01/06/2016 20:43, Giulio Camuffo wrote:
> weston_compositor_xkb_destroy() is called automatically so having only
> weston_compositor_xkb_init() to be called by the user was a bit weird.
> So rename it so that it makes more sense.
> Also export it, since libweston compositors need to call it.
> v2: renamed xkb_init to set_xkb_rule_names
> src/compositor.h | 4 ++--
> src/input.c | 12 ++++++------
> src/main.c | 2 +-
> 3 files changed, 9 insertions(+), 9 deletions(-)
That rename sounds like a good idea, the fact that init is done there is
then a mere implementation detail, so:
Reviewed-by: Quentin Glidic <sardemff7+git at sardemff7.net>
Quentin “Sardem FF7” Glidic
More information about the wayland-devel