[PATCH wayland-protocols v3] Add screensaver idle inhibitor protocol

Bryce Harrington bryce at osg.samsung.com
Tue Jun 7 19:35:09 UTC 2016


On Fri, Jun 03, 2016 at 11:41:12AM +0300, Pekka Paalanen wrote:
> On Thu, 2 Jun 2016 14:33:42 -0700
> Bryce Harrington <bryce at osg.samsung.com> wrote:
> 
> > On Wed, May 18, 2016 at 04:11:39PM +0300, Pekka Paalanen wrote:
> > > On Thu, 24 Mar 2016 11:14:33 -0700
> > > Bryce Harrington <bryce at osg.samsung.com> wrote:
> > >   
> > > > This interface allows disabling of screensaver/screenblanking on a
> > > > per-surface basis.  As long as the surface remains visible and
> > > > non-occluded it blocks the screensaver, etc. from activating on the
> > > > output(s) that the surface is visible on.
> > > > 
> > > > To uninhibit, simply destroy the inhibitor object.  
> > > 
> > > Hi,
> > > 
> > > ok, that sounds good.
> > >   
> > > > Signed-off-by: Bryce Harrington <bryce at bryceharrington.org>
> > > > ---
> > > > v2: Rename protocol to idle-inhibit
> > > >  + Use "idle" rather than "screensaver".  People likely to be interested
> > > >    in this protocol would know the difference between "blanking", "dpms",
> > > >    and literal "screensavers", so don't lead them to think that this only
> > > >    deals with the latter.  The protocol addresses all manner of idle
> > > >    behaviors, so is a more accurate name.
> > > >  + Standardize nomenclature to "idle-manager" and "inhibitor" for clarity.
> > > >    "inhibition_inhibit" was just too cumbersome.  
> > > 
> > > Alright!
> > >   
> > > > 
> > > >  Makefile.am                                        |  1 +
> > > >  unstable/idle-inhibit/README                       |  4 ++
> > > >  unstable/idle-inhibit/idle-inhibit-unstable-v1.xml | 78 ++++++++++++++++++++++
> > > >  3 files changed, 83 insertions(+)
> > > >  create mode 100644 unstable/idle-inhibit/README
> > > >  create mode 100644 unstable/idle-inhibit/idle-inhibit-unstable-v1.xml
> > > > 
> > > > diff --git a/Makefile.am b/Makefile.am
> > > > index 5926a41..ac497d8 100644
> > > > --- a/Makefile.am
> > > > +++ b/Makefile.am
> > > > @@ -5,6 +5,7 @@ unstable_protocols =								\
> > > >  	unstable/text-input/text-input-unstable-v1.xml				\
> > > >  	unstable/input-method/input-method-unstable-v1.xml			\
> > > >  	unstable/xdg-shell/xdg-shell-unstable-v5.xml				\
> > > > +	unstable/idle-inhibit/idle-inhibit-unstable-v1.xml	\
> > > >  	$(NULL)
> > > >  
> > > >  nobase_dist_pkgdata_DATA =							\
> > > > diff --git a/unstable/idle-inhibit/README b/unstable/idle-inhibit/README
> > > > new file mode 100644
> > > > index 0000000..396e871
> > > > --- /dev/null
> > > > +++ b/unstable/idle-inhibit/README
> > > > @@ -0,0 +1,4 @@
> > > > +Screensaver inhibition protocol
> > > > +
> > > > +Maintainers:
> > > > +Bryce Harrington <bryce at osg.samsung.com>
> > > > diff --git a/unstable/idle-inhibit/idle-inhibit-unstable-v1.xml b/unstable/idle-inhibit/idle-inhibit-unstable-v1.xml
> > > > new file mode 100644
> > > > index 0000000..a8c8a85
> > > > --- /dev/null
> > > > +++ b/unstable/idle-inhibit/idle-inhibit-unstable-v1.xml
> > > > @@ -0,1 +1,78 @@
> > > > +<?xml version="1.0" encoding="UTF-8"?>
> > > > +<protocol name="idle_inhibit_unstable_v1">
> > > > +
> > > > +  <copyright>
> > > > +    Copyright © 2015-2016 Samsung Electronics Co., Ltd
> > > > +
> > > > +    Permission is hereby granted, free of charge, to any person obtaining a
> > > > +    copy of this software and associated documentation files (the "Software"),
> > > > +    to deal in the Software without restriction, including without limitation
> > > > +    the rights to use, copy, modify, merge, publish, distribute, sublicense,
> > > > +    and/or sell copies of the Software, and to permit persons to whom the
> > > > +    Software is furnished to do so, subject to the following conditions:
> > > > +
> > > > +    The above copyright notice and this permission notice (including the next
> > > > +    paragraph) shall be included in all copies or substantial portions of the
> > > > +    Software.
> > > > +
> > > > +    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
> > > > +    IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
> > > > +    FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
> > > > +    THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
> > > > +    LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
> > > > +    FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
> > > > +    DEALINGS IN THE SOFTWARE.
> > > > +  </copyright>
> > > > +
> > > > +  <interface name="zwp_idle_inhibit_manager_v1" version="1">
> > > > +    <description summary="control behavior when display idles">
> > > > +      This interface permits inhibiting the idle behavior such as screen
> > > > +      blanking, locking, and screensaving.  The client binds the idle manager
> > > > +      globally, then creates idle-inhibitor objects for each surface.
> > > > +
> > > > +      Warning! The protocol described in this file is experimental and
> > > > +      backward incompatible changes may be made. Backward compatible changes
> > > > +      may be added together with the corresponding interface version bump.
> > > > +      Backward incompatible changes are done by bumping the version number in
> > > > +      the protocol and interface names and resetting the interface version.
> > > > +      Once the protocol is to be declared stable, the 'z' prefix and the
> > > > +      version number in the protocol and interface names are removed and the
> > > > +      interface version number is reset.
> > > > +    </description>
> > > > +
> > > > +    <request name="create_inhibitor">
> > > > +      <description summary="create a new inhibitor object">
> > > > +	Create a new inhibitor object associated with the given surface.
> > > > +      </description>
> > > > +      <arg name="id" type="new_id" interface="zwp_idle_inhibitor_v1"/>
> > > > +      <arg name="surface" type="object" interface="wl_surface"
> > > > +	   summary="the surface that inhibits the idle behavior"/>
> > > > +    </request>  
> > > 
> > > This interface is missing a destructor. It is the only way the
> > > compositor could destroy the wl_resource before the client disconnects.
> > > 
> > > All interfaces need a way to destroy the object.
> > >   
> > > > +  </interface>
> > > > +
> > > > +  <interface name="zwp_idle_inhibitor_v1" version="1">
> > > > +    <description summary="context object for inhibiting idle behavior">
> > > > +      An idle inhibitor prevents the output that the surface is visible on  
> > > 
> > > "the associated surface", to be crystal clear.
> > >   
> > > > +      from being blanked, dimmed, locked, set to power save, or otherwise
> > > > +      obscured due to lack of user interaction.  Any active screensaver
> > > > +      processes are also temporarily blocked from displaying.
> > > > +
> > > > +      If the surface is destroyed, disabled, becomes occluded or otherwise  
> > > 
> > > What does "disabled" mean? Are you looking for "unmapped"?
> > > 
> > > Should we say "completely occluded"?  
> > 
> > I am not certain that we should limit it to that, in case a compositor
> > wanted to have a partial occlusion state be reason for not honoring
> > inhibition requests.  But it's hard to conceptualize the potential use
> > cases here.
> 
> Hi,
> 
> right, it might be better to list the things you can be explicit about
> and leave rest for a vague or-any-other-thing.
> 
> It might help to step back and think how you would explain to another
> person what you actually want to mean here. It will be a verbose
> description that should be much easier to compress into a spec wording
> afterwards than to come up with spec wording initially. I do that
> when I realize I'm struggling with wording.
> 
> > > > +      loses visibility, the screen behavior is restored to normal; if the  
> > > 
> > > I'd change "the screen behavior is restored to normal" to "the
> > > inhibitor becomes ineffective". Restoring to normal is a bit vague, and
> > > might not even be true if there are other inhibitors in effect.  
> > 
> > Hmm, how about "the inhibition request will not be honored by the
> > compositor?"
> 
> Sounds fine, though I'd use "inhibitor" rather than "inhibition
> request" since we are not talking about a protocol message here. It
> would be good to restrict the use of "request" as a noun to
> client-to-server protocol messages to avoid confusion.

Okay, some further tweakages:

      An idle inhibitor prevents the output that the associated surface
      is drawn on from being blanked, dimmed, locked, set to power save,
      or be set to a state where it is not visually usable due to lack
      of user interaction.  Any active screensaver animation processes
      are also blocked from displaying.

      If the surface is destroyed, unmapped, becomes occluded, loses
      visibility, or otherwise becomes not visually relevant for the
      user, the idle inhibitor will not be honored by the compositor; if
      the surface subsequently regains visibility the inhibitor takes
      effect once again.

This explicitly gives the compositor more flexibility in defining what
it'll honor and what it'll inhibit in response.

Bryce


More information about the wayland-devel mailing list