[PATCH wayland-protocols v3] Add screensaver idle inhibitor protocol

Giulio Camuffo giuliocamuffo at gmail.com
Mon Mar 28 08:10:22 UTC 2016


2016-03-24 20:14 GMT+02:00 Bryce Harrington <bryce at osg.samsung.com>:
> This interface allows disabling of screensaver/screenblanking on a
> per-surface basis.  As long as the surface remains visible and
> non-occluded it blocks the screensaver, etc. from activating on the
> output(s) that the surface is visible on.
>
> To uninhibit, simply destroy the inhibitor object.
>
> Signed-off-by: Bryce Harrington <bryce at bryceharrington.org>
> ---
> v2: Rename protocol to idle-inhibit
>  + Use "idle" rather than "screensaver".  People likely to be interested
>    in this protocol would know the difference between "blanking", "dpms",
>    and literal "screensavers", so don't lead them to think that this only
>    deals with the latter.  The protocol addresses all manner of idle
>    behaviors, so is a more accurate name.
>  + Standardize nomenclature to "idle-manager" and "inhibitor" for clarity.
>    "inhibition_inhibit" was just too cumbersome.
>
>  Makefile.am                                        |  1 +
>  unstable/idle-inhibit/README                       |  4 ++
>  unstable/idle-inhibit/idle-inhibit-unstable-v1.xml | 78 ++++++++++++++++++++++
>  3 files changed, 83 insertions(+)
>  create mode 100644 unstable/idle-inhibit/README
>  create mode 100644 unstable/idle-inhibit/idle-inhibit-unstable-v1.xml
>
> diff --git a/Makefile.am b/Makefile.am
> index 5926a41..ac497d8 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -5,6 +5,7 @@ unstable_protocols =                                                            \
>         unstable/text-input/text-input-unstable-v1.xml                          \
>         unstable/input-method/input-method-unstable-v1.xml                      \
>         unstable/xdg-shell/xdg-shell-unstable-v5.xml                            \
> +       unstable/idle-inhibit/idle-inhibit-unstable-v1.xml      \
>         $(NULL)
>
>  nobase_dist_pkgdata_DATA =                                                     \
> diff --git a/unstable/idle-inhibit/README b/unstable/idle-inhibit/README
> new file mode 100644
> index 0000000..396e871
> --- /dev/null
> +++ b/unstable/idle-inhibit/README
> @@ -0,0 +1,4 @@
> +Screensaver inhibition protocol
> +
> +Maintainers:
> +Bryce Harrington <bryce at osg.samsung.com>
> diff --git a/unstable/idle-inhibit/idle-inhibit-unstable-v1.xml b/unstable/idle-inhibit/idle-inhibit-unstable-v1.xml
> new file mode 100644
> index 0000000..a8c8a85
> --- /dev/null
> +++ b/unstable/idle-inhibit/idle-inhibit-unstable-v1.xml
> @@ -0,1 +1,78 @@
> +<?xml version="1.0" encoding="UTF-8"?>
> +<protocol name="idle_inhibit_unstable_v1">
> +
> +  <copyright>
> +    Copyright © 2015-2016 Samsung Electronics Co., Ltd
> +
> +    Permission is hereby granted, free of charge, to any person obtaining a
> +    copy of this software and associated documentation files (the "Software"),
> +    to deal in the Software without restriction, including without limitation
> +    the rights to use, copy, modify, merge, publish, distribute, sublicense,
> +    and/or sell copies of the Software, and to permit persons to whom the
> +    Software is furnished to do so, subject to the following conditions:
> +
> +    The above copyright notice and this permission notice (including the next
> +    paragraph) shall be included in all copies or substantial portions of the
> +    Software.
> +
> +    THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
> +    IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
> +    FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
> +    THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
> +    LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
> +    FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
> +    DEALINGS IN THE SOFTWARE.
> +  </copyright>
> +
> +  <interface name="zwp_idle_inhibit_manager_v1" version="1">
> +    <description summary="control behavior when display idles">
> +      This interface permits inhibiting the idle behavior such as screen
> +      blanking, locking, and screensaving.  The client binds the idle manager
> +      globally, then creates idle-inhibitor objects for each surface.
> +
> +      Warning! The protocol described in this file is experimental and
> +      backward incompatible changes may be made. Backward compatible changes
> +      may be added together with the corresponding interface version bump.
> +      Backward incompatible changes are done by bumping the version number in
> +      the protocol and interface names and resetting the interface version.
> +      Once the protocol is to be declared stable, the 'z' prefix and the
> +      version number in the protocol and interface names are removed and the

Kind ok OT, but reading this made me wonder if it would make sense to
leave the version number in the interface name even when protocols are
stable. Sometimes problems slip through stabilization processes and it
may still be needed to do a backward incompatible change.

> +      interface version number is reset.
> +    </description>
> +
> +    <request name="create_inhibitor">
> +      <description summary="create a new inhibitor object">
> +       Create a new inhibitor object associated with the given surface.
> +      </description>
> +      <arg name="id" type="new_id" interface="zwp_idle_inhibitor_v1"/>
> +      <arg name="surface" type="object" interface="wl_surface"
> +          summary="the surface that inhibits the idle behavior"/>
> +    </request>
> +  </interface>
> +
> +  <interface name="zwp_idle_inhibitor_v1" version="1">
> +    <description summary="context object for inhibiting idle behavior">
> +      An idle inhibitor prevents the output that the surface is visible on
> +      from being blanked, dimmed, locked, set to power save, or otherwise
> +      obscured due to lack of user interaction.  Any active screensaver
> +      processes are also temporarily blocked from displaying.
> +
> +      If the surface is destroyed, disabled, becomes occluded or otherwise
> +      loses visibility, the screen behavior is restored to normal; if the
> +      surface subsequently regains visibility or is unoccluded, the inhibitor
> +      takes effect once again.
> +
> +      Note that in the case of a compound window (a surface with
> +      sub-surfaces), a separate inhibitor object may be needed for each
> +      wl_surface.

I think this could be a problem. Say a video player client uses a
library to decode the video, and that library shows the video on a
subsurface, child of a surface the client provides. I'd argue the
inhibition should be done by the client and not by the library (the
libray could be used by some clients not wanting inhibition, maybe
they just show an animated background over which the real content is
shown).
So in order to use this extension the client would need to have access
to the surface the library uses, and libraries may not be happy to
provide that as it breaks encapsulation.
So i think Pekka's suggestion[0] is best, let subsurfaces inherit the
inhibition state from the parent.

0: https://lists.freedesktop.org/archives/wayland-devel/2015-November/025795.html


Cheers,
Giulio

> +    </description>
> +
> +    <request name="destroy" type="destructor">
> +      <description summary="destroy the idle inhibitor object">
> +       This restores screensaver/blanking/et al behaviors to their normal
> +       state and destructs the idle inhibitor object.
> +      </description>
> +    </request>
> +
> +  </interface>
> +</protocol>
> --
> 1.9.1
>
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/wayland-devel


More information about the wayland-devel mailing list