[PATCH weston v4 03/14] compositor-wayland: rename wayland_output_init_from_config

Benoit Gschwind gschwind at gnu-log.net
Tue May 10 20:47:46 UTC 2016


Rename wayland_output_init_from_config to weston_wayland_output_config_init
to prepare the following patch :
"compositor-wayland: move configuration parsing to weston"

Signed-off-by: Benoit Gschwind <gschwind at gnu-log.net>
---
 src/compositor-wayland.c | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)

diff --git a/src/compositor-wayland.c b/src/compositor-wayland.c
index 4799f90..adeb59b 100644
--- a/src/compositor-wayland.c
+++ b/src/compositor-wayland.c
@@ -1091,11 +1091,15 @@ err_name:
 	return NULL;
 }
 
+/*
+ * Do not follow legacy naming convension to prepare the following patch:
+ * "compositor-wayland: move configuration parsing to weston"
+ */
 static void
-wayland_output_init_from_config(struct weston_wayland_backend_output_config *output,
-				struct weston_config_section *config_section,
-				int option_width, int option_height,
-				int option_scale)
+weston_wayland_output_config_init(struct weston_wayland_backend_output_config *output,
+				  struct weston_config_section *config_section,
+				  int option_width, int option_height,
+				  int option_scale)
 {
 	char *mode, *t, *str;
 	unsigned int slen;
@@ -2441,8 +2445,8 @@ load_wayland_backend_config(struct weston_compositor *compositor, int *argc,
 		if (!oc)
 			goto err_outputs;
 
-		wayland_output_init_from_config(oc, section, width,
-						height, scale);
+		weston_wayland_output_config_init(oc, section, width,
+						  height, scale);
 		--count;
 	}
 
-- 
2.7.3



More information about the wayland-devel mailing list