[PATCH weston v4 07/14] compositor-wayland: rename load_wayland_backend_config arg "config" to wc
Benoit Gschwind
gschwind at gnu-log.net
Tue May 10 20:47:50 UTC 2016
Rename the load_wayland_backend_config arg "config" to use this name for
another variable in the following patch. It also follow the legacy
naming scheme.
Signed-off-by: Benoit Gschwind <gschwind at gnu-log.net>
---
src/main.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/main.c b/src/main.c
index 57a48b6..24321e7 100644
--- a/src/main.c
+++ b/src/main.c
@@ -1120,7 +1120,7 @@ wayland_backend_config_add_new_output(struct weston_wayland_backend_config *new_
static int
load_wayland_backend_config(struct weston_compositor *compositor, int *argc,
- char *argv[], struct weston_config *config,
+ char *argv[], struct weston_config *wc,
struct weston_wayland_backend_config *out_config)
{
struct weston_wayland_backend_config new_config = {{ 0, }};
@@ -1157,7 +1157,7 @@ load_wayland_backend_config(struct weston_compositor *compositor, int *argc,
new_config.base.struct_size = sizeof(struct weston_wayland_backend_config);
new_config.base.struct_version = WESTON_WAYLAND_BACKEND_CONFIG_VERSION;
- section = weston_config_get_section(config, "shell", NULL, NULL);
+ section = weston_config_get_section(wc, "shell", NULL, NULL);
weston_config_section_get_string(section, "cursor-theme",
&new_config.cursor_theme, NULL);
weston_config_section_get_int(section, "cursor-size",
@@ -1185,7 +1185,7 @@ load_wayland_backend_config(struct weston_compositor *compositor, int *argc,
}
section = NULL;
- while (weston_config_next_section(config, §ion, §ion_name)) {
+ while (weston_config_next_section(wc, §ion, §ion_name)) {
if (!section_name || strcmp(section_name, "output") != 0)
continue;
weston_config_section_get_string(section, "name", &name, NULL);
--
2.7.3
More information about the wayland-devel
mailing list