[PATCH weston v4 10/14] compositor-wayland: rename wayland_backend_config_release function

Benoit Gschwind gschwind at gnu-log.net
Tue May 10 20:47:53 UTC 2016


Rename the wayland_backend_config_release function to
weston_wayland_backend_config_release to follow legacy naming scheme.

Signed-off-by: Benoit Gschwind <gschwind at gnu-log.net>
---
 src/main.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/main.c b/src/main.c
index 28e7e1d..e03bde7 100644
--- a/src/main.c
+++ b/src/main.c
@@ -1086,7 +1086,7 @@ weston_wayland_output_config_init(struct weston_wayland_backend_output_config *o
 }
 
 static void
-wayland_backend_config_release(struct weston_wayland_backend_config *new_config)
+weston_wayland_backend_config_release(struct weston_wayland_backend_config *new_config)
 {
 	int i;
 
@@ -1230,7 +1230,7 @@ load_wayland_backend_config(struct weston_compositor *compositor, int *argc,
 	return 0;
 
 err_outputs:
-	wayland_backend_config_release(out_config);
+	weston_wayland_backend_config_release(out_config);
 	return -1;
 }
 
@@ -1248,7 +1248,7 @@ load_wayland_backend(struct weston_compositor *c, char const * backend,
 
 	/* load the actual wayland backend and configure it */
 	ret = load_backend_new(c, backend, &config.base);
-	wayland_backend_config_release(&config);
+	weston_wayland_backend_config_release(&config);
 	return ret;
 }
 
-- 
2.7.3



More information about the wayland-devel mailing list