[PATCH weston 0/5] gl-renderer: Renaming of things and minor improvements

Miguel A. Vico mvicomoya at nvidia.com
Wed May 11 12:48:13 UTC 2016


Hi,

Feedback for the first revision has been addressed. Here is a new series that
basically splits the orginal patch into several little pieces.

Additionally, gl_renderer_create() has been renamed to
gl_renderer_display_create() as per Daniel Stone's request.

Thanks,
Miguel.


Summary:
  gl-renderer: Accept non-NULL empty <visual_id> arrays
  gl-renderer: Add <platform_attribs> param to gl_renderer_display_create
  gl-renderer: Rename <attribs> param of gl_renderer to <config_attribs>
  gl-renderer: Rename gl_renderer::output_create to output_window_create
  gl-renderer: Rename gl_renderer_create to gl_renderer_display_create

  src/compositor-drm.c     |  5 +++--
  src/compositor-fbdev.c   |  5 +++--
  src/compositor-wayland.c |  5 +++--
  src/compositor-x11.c     |  7 ++++---
  src/gl-renderer.c        | 22 +++++++++++-----------
  src/gl-renderer.h        |  9 +++++----
  6 files changed, 29 insertions(+), 24 deletions(-)


NVIDIA GmbH, Wuerselen, Germany, Amtsgericht Aachen, HRB 8361
Managing Director: Karen Theresa Burns

-----------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution
is prohibited.  If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
-----------------------------------------------------------------------------------


More information about the wayland-devel mailing list