[ANNOUNCE] libinput 1.4.901
Peter Hutterer
peter.hutterer at who-t.net
Wed Sep 7 03:56:14 UTC 2016
The first RC for libinput 1.5 is available
A large part of this development cycle was internal cleanups and
improvements to the test suite, only few new features were added.
For touchpads, we now have a new configuration option to allow a 1/2/3
finger tap be mapped to left, middle and right, respectively. The
default remains at left/right/middle. For more details, see the
documentation for
libinput_device_config_tap_set_button_map()
In the disable-while-typing code we now ignore modifier combinations like
ctrl+s to avoid unnecessary timeouts and delays.
Other touchpad-related fixes include more responsive two-finger scrolling
and better touch point transition handling (i.e. less pointer jumps after
tapping and two-finger scrolling).
For tablets we now have automatic touch arbitration in userspace, i.e. we
disable the touch input whenever a pen is in proximity to avoid erroneous
pointer moves. Touch arbitration is currently handled by the kernel but is
being phased out over the next couple of kernel releases. In the future this
may allow for smart touch arbitration based on input areas, for now we
simply copy the kernel's behavior and turn touch events off.
The rest are assorted fixes and the aforementioned internal cleanups.
As usual, the git shortlog is below
Peter Hutterer (89):
touchpad: whitespace fix
evdev_device_suspend() is a void function
Change a few functions that only ever returned 0 to voids
Switch a bunch of internal functions from int to bool
touchpad: change clickfinger check distance function to a bool
touchpad: change palm detection trigger functions to bools
touchpad: change the sanity check function to a bool
evdev: prefix "tablet unknown to libwacom" error with the device name
evdev: add helper functions to convert between units and mm
touchpad: change manual calculations of dimensions to helper functions
udev: don't overwrite a previously set device group
test: fix prefix for the gestures time test
test: namespace the bitfield helper tests
test: make the interfaces static
doc: add links to the two debugging tools as examples
touchpad: use the udev ID_INPUT_TOUCHPAD_INTEGRATION property if available
test: make the valgrind test an actual dependency of the test run
test: store created udev rules in a list for easier deletion
test: merge all tests into a single binary
test: only init the device rules once
test: make sure we remove all udev rules when we SIGINT the test
test: restore the hwdb/udev rules on SIGINT
Revert "test: create a lock file to avoid parallel udev reloads during device add"
test: drop the sysname comparison in the device add/remove test
test: add a make-like job control to run tests in parallel
test: remove NOTPARALLEL
test: split the tap tests into more tap groups
test: if a filter is specified, don't parallelize jobs by default
test: if we're in a debugger, use single-fork mode only
evdev: fix typo "device device"
test: just use litest_add_device if we don't have overrides
Include config.h from libinput-util.h
udev: check wacom devices for a paired product id
test: add dwt modifier/fkey test cases
touchpad: ignore modifier key combos for dwt
gestures: reduce the 2fg scroll timeout to 150ms
doc: add some info about configuring devices in wayland/xorg
doc: add build instructions
evdev: move the fallback dispatch creation to evdev_configure_device
evdev: return the dispatch method from evdev_configure_device
evdev: split out slot init
evdev: move axis dimension handling into a single helper function
evdev: move the mt struct into the evdev dispatch struct
evdev: move the relative deltas for normal devices to the fallback dispatch
evdev: move pending_event to the evdev_dispatch struct
evdev: move the keyboard mask into the fallback dispatch
evdev: split evdev_dispatch and fallback_dispatch into separate entities
evdev: reshuffle the evdev_device struct fields
evdev: switch three ints to booleans
evdev: move the abs point into the fallback dispatch
evdev: pass the dispatch interface around
evdev: rename all fallback-specific functions to a fallback_ prefix
doc: split middle button emulation into a separate page
Add configurable button map to tappings
touchpad: implement configurable button mapping for tapping
test: implement tests for configurable tap button mappings
doc: fix wrong argument to udevadm hwdb
touchpad: on a non-clickpad, reset the motion history on nfingers change
Read the horizontal wheel click angle property if available
touchpad: reset the edge scroll state on touch up if edge scroll is disabled
tablet: fix minor coding style issue
test: add a helper function to compare the event type
test: only abort when we fail to add any tests and we have no filters
doc: drop HTML_TIMESTAMP
test: prevent cursor jumps in the various tap tests
touchpad: always reset the motion history on finger changes
evdev: recognize and use ID_INPUT_TRACKBALL
touchpad: line width fix
test: add the valgrind test suite output to the distcleanfiles
evdev: fix handling of click wheel on parsing errors
evdev: add quirk for the HP85810 touchpad
test: add a Wacom HID 4800 test device
test: change the matrix delta test to use a tip-down event
tablet: if a serial comes in late, discard it
udev: add missing touchpad model name for the HP 8510w
udev: fix comment describing permitted match strings
test: add test for touchpad disabling on external mouse
doc: extend build instructions for dependencies
test: add trackpoint palm detection tests
evdev: split out mt event flushing
evdev: let the fallback_flush... function decide whether a frame is needed
evdev: don't send frame events if we filtered the touch event
evdev: release current touches when the device is suspended
test: move the Intuos 5 and Cintiq 13HD test tablets into the same device group
test: add litest_assert_touch_sequence helper
evdev: split resetting to a neutral state out
tablet: add touch arbitration
Force the HP Stream 11 touchpad as a clickpad
configure.ac: libinput 1.5rc1
Reynaldo H. Verdejo Pinochet (1):
buildsystem: add missing uninstalled pkg-config infra
git tag: 1.4.901
http://www.freedesktop.org/software/libinput/libinput-1.4.901.tar.xz
MD5: c8c868a3151016c45505c1a9e4fb13dc libinput-1.4.901.tar.xz
SHA1: bdd249c1c3092c3633229aef9513d9989989106a libinput-1.4.901.tar.xz
SHA256: ad7de4c67ed2748934afcc141398c7382bc2062d8dbf9a0e8115c895d349d0a4 libinput-1.4.901.tar.xz
PGP: http://www.freedesktop.org/software/libinput/libinput-1.4.901.tar.xz.sig
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20160907/6fcca28f/attachment.sig>
More information about the wayland-devel
mailing list