[PATCH wayland v6] util: Document wl_list methods

Pekka Paalanen ppaalanen at gmail.com
Mon Sep 26 12:49:55 UTC 2016


On Thu, 22 Sep 2016 22:11:39 -0700
Bryce Harrington <bryce at osg.samsung.com> wrote:

> On Thu, Sep 22, 2016 at 09:59:37PM -0500, Yong Bakos wrote:
> > From: Yong Bakos <ybakos at humanoriented.com>
> > 
> > Add doxygen comment blocks to all wl_list methods.
> > 
> > Signed-off-by: Yong Bakos <ybakos at humanoriented.com>  
> 
> Reviewed-by: Bryce Harrington <bryce at osg.samsung.com>
> 
> One extremely minor wording suggestion below only if you do another rev.
> But this all looks extremely good; will be nice to get the wl_list
> documentation shaped up, thanks.
> 
> Bryce
> 
> > ---
> > v6: Change description to doubly-linked list (pq)
> > v5: Change description to linked-list [err]
> >     Clarify uses of `wl_list_init` (pq)
> > v4: Fix variable name in sample code. (pq)
> >     Remove implemenetation details of pointer state. (pq)
> >     Remove note about __typeof__ entirely.
> >     - it's not helpful as a note or a code comment either
> >     Change sample code indentation to just spaces. (pq)
> >     Use _list suffix for list in sample code. (pq)
> >     Use 'iterate' instead of enumerate, for consistency. (pq)
> >     Note that only removing 'pos' is safe for *_safe methods. (pq, giucam)
> > v3: Standardize on term 'element', to match param names, tests, and other text.
> >     Use 'relates' for macros (instead of 'memberof').
> > v2: Refine the writing for clarity.
> >     Add dox for wl_list macros, omitted in v1.
> >     Add notices for unsafe operations and invalid states (giucam, pq)
> >  src/wayland-util.h | 224 +++++++++++++++++++++++++++++++++++++++++++----------
> >  1 file changed, 184 insertions(+), 40 deletions(-)
> > 

> > +/**
> > + * Inserts all of the elements of one list into another, after the element
> > + * represented by \p list.
> > + *
> > + * \note This leaves \p other itself in an invalid state.  
> 
> Might read better if you take the word 'itself' out?
> 

Hi,

I made the change Bryce suggested and pushed the result:
   454df51..f7e1dcc  master -> master


Thanks,
pq
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 811 bytes
Desc: OpenPGP digital signature
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20160926/a50d3a8f/attachment.sig>


More information about the wayland-devel mailing list