[PATCH weston v4 0/4] simple-dmabuf-drm: Support etnaviv and freedreno cleanups

Guido Günther agx at sigxcpu.org
Mon Mar 19 16:45:17 UTC 2018


Changes from v3:
    - Use ALIGN macro by default
    - Don't multiply by bpp twice
    - unmap buffer

Former patches 1-3 where already applied. Thanks!

Changes from v2:
    - Use stride to calculate buffer size (etnaviv)
    - Use stride to calculate buffer size (freedreno)
    - Use less generic name for ALIGN macro

Changes from v1:
    - Split up changes
    - autoconf:
      - don't define unused have_ variables. Use true instead to
        prevent abort of PKG_CHECK_MODULES
      - use && instead of -a in test
      - properly check variables
    - use vfunc for drm_device_destroy


Guido Günther (4):
  simple-dmabuf-drm: Always define ALIGN
  simple-dmabuf-drm: use large enough buffer (freedreno)
  simple-dmabuf-drm: 0 is a valid fd (freedreno)
  simple-dmabuf-drm: support etnaviv drm as well

 Makefile.am                 |  1 +
 clients/simple-dmabuf-drm.c | 91 ++++++++++++++++++++++++++++++++++++++++++---
 configure.ac                |  5 ++-
 3 files changed, 90 insertions(+), 7 deletions(-)

-- 
2.16.1



More information about the wayland-devel mailing list