[PATCH weston v5 0/3] simple-dmabuf-drm: Support etnaviv and freedreno cleanups
Guido Günther
agx at sigxcpu.org
Tue Mar 20 08:41:57 UTC 2018
Former patches 1-2 where already applied thanks Derek.
Changes from v4
- configure: use true if etnaviv drm was not found as with
other drm backends (avoids an unused variable assignment)
- configure: use (hopefully) correct english
- simplify several if (cond) return 1; return 0; statements
- unmap buffer
Former patches 1-3 where already applied thanks Peka.
Changes from v3:
- Use ALIGN macro by default
- Don't multiply by bpp twice
- unmap buffer
Changes from v2:
- Use stride to calculate buffer size (etnaviv)
- Use stride to calculate buffer size (freedreno)
- Use less generic name for ALIGN macro
Changes from v1:
- Split up changes
- autoconf:
- don't define unused have_ variables. Use true instead to
prevent abort of PKG_CHECK_MODULES
- use && instead of -a in test
- properly check variables
- use vfunc for drm_device_destroy
Guido Günther (3):
simple-dmabuf-drm: 0 is a valid fd (freedreno)
simple-dmabuf-drm: simplify fd_map_bo
simple-dmabuf-drm: support etnaviv drm as well
Makefile.am | 1 +
clients/simple-dmabuf-drm.c | 79 +++++++++++++++++++++++++++++++++++++++------
configure.ac | 5 ++-
3 files changed, 75 insertions(+), 10 deletions(-)
--
2.16.1
More information about the wayland-devel
mailing list