Unable to run X-clients over Weston through XWayland

Devashish Tiwari devashish at cdot.in
Thu Feb 6 05:21:22 UTC 2020


As we discussed previously, I have been trying to run X-clients on my Weston + Xwayland environment.

I think I have come to a point where my Wayland succeeds in launching Xwayland, i.e., I am able to get those three prints you mentioned in the trailing email.

When I run xeyes on my Weston+Xwayland environment, I am getting following in /var/log/weston.log :

Spawned Xwayland server, pid 1474                  
Failed to create EGL context with GL                    
EGL setup failed, disabling glamor                                                                                           
Failed to initialize glamor, falling back to sw                                                                

[12:44:13.529] xfixes version: 5.0                                            
[12:44:13.554] created wm, root 77                           

The XKEYBOARD keymap compiler (xkbcomp) reports:                       
> Warning:          Unsupported high keycode 372 for name <I372> ignored   
>                   X11 cannot support keycodes above 255.                     
>                   This warning only shows for the first high keycode.        
Errors from xkbcomp are not fatal to the X server                     

(EE) failed to read Wayland events: Broken pipe     

However, on the terminal, there is a delay of 1-2 seconds and then I get following:

root at am57xx-evm:/mnt# ./xeyes 
Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
X connection to :0 broken (explicit kill or server shutdown).

And after that weston stops and it doesn't work even when I do "/etc/init.d/weston start".

I have to reboot the board again to make weston work.

Can you tell what did go wrong here?

On Wed, 11 Dec 2019 12:10:31 +0200, Pekka Paalanen wrote

On Wed, 11 Dec 2019 14:07:50 +0530 
 "Devashish Tiwari" <devashish at cdot.in> wrote:

 > Hi, 
 > Thanks for your response. 
 > I am still not sure about how to run X-clients (xeyes, xcalc, xclock 
 > etc) on Weston running with xwayland module. 
 > I did: 
 >  export DISPLAY=':0' 
 > and tried to run Xclient. But I am getting the same error: 
 > Error: Can't open display: :0 
 > I don't know what's the reason behind this, even though Weston is 
 > listening on the X11 socket, as I am getting "xserver listening on 
 > display :0" in weston.log 


 then I am equally at loss, too.

 Please run the X11 app with 'strace' and see what exactly fails.

 > Can you point me at some basic X-client/app which I'd be able to run 
 > successfully on my weston+xwayland environment?

 You already tried them, and I can't see anything wrong in what you 

 Except, you didn't say Weston logging a message where it actually 
 succeeded in launching Xwayland. Something like this:

 [12:08:05.666] xserver listening on display :1 
 [12:08:11.198] Spawned Xwayland server, pid 26539 
 [12:08:11.475] xfixes version: 5.0 
 [12:08:11.491] created wm, root 924

 Those last three lines indicate success.



Thanks & Regards, 
Devashish Tiwari
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20200206/322f4fd7/attachment.htm>

More information about the wayland-devel mailing list