Unable to run X-clients over Weston through XWayland

Pekka Paalanen ppaalanen at gmail.com
Thu Feb 6 11:21:49 UTC 2020

On Thu, 6 Feb 2020 16:11:04 +0530
"Devashish Tiwari" <devashish at cdot.in> wrote:

> So, I ran weston using strace this time and recorded the output on
> running xeyes in a different terminal. 

That does not seem to tell me anything. The actual weston
log/stdout/stderr would have been more helpful.

> --- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x8} ---
> +++ killed by SIGSEGV (core dumped) +++

This at least proves it's a crash like I suspected.

> Also, a core dump is recorded at /var/lib/systemd/coredump/ when
> weston crashes. The file name is:
> core.weston.0.4715aafef56147c387ba67a68bd526ed.1384.1580990319000000.xz

Use the command coredumpctl. For more information,
see 'man coredumpctl'.

> I am not sure on how to analyze this core dump file. But I looked at
> wiki forums and found out that it should be done using gdb. So when I
> extracted this file and ran it using gdb, it showed following:
> root at am57xx-evm:/mnt# gdb /usr/bin/weston core.weston.0.4715aafef56147c387ba67a68bd526ed.1384.1580990319000000
> GNU gdb (GDB) 8.2
> Copyright (C) 2018 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
> Type "show copying" and "show warranty" for details.
> This GDB was configured as "arm-linux-gnueabi".
> Type "show configuration" for configuration details.
> For bug reporting instructions, please see:
> <http://www.gnu.org/software/gdb/bugs/>.
> Find the GDB manual and other documentation resources online at:
>     <http://www.gnu.org/software/gdb/documentation/>.
> For help, type "help".
> Type "apropos word" to search for commands related to "word"...
> Reading symbols from /usr/bin/weston...done.
> [New LWP 1384]
> [Thread debugging using libthread_db enabled]
> Using host libthread_db library "/lib/libthread_db.so.1".
> Core was generated by `weston --idle-time=0'.
> Program terminated with signal SIGSEGV, Segmentation fault.
> #0  frame_resize_inside (frame=0x0, width=150, height=100) at shared/frame.c:498

The only place where that should get called from is inside Weston's XWM
where it attempts to decorate an X11 window. frame=0x0 is definitely wrong.

> 498    shared/frame.c: No such file or directory.
> I don't know how to proceed further. Can you suggest something?

Is that the end of the stack trace? There should be more. Please seek
guidance on debugging on your platform in general. You may need to make
sure weston is built with debug info and that the debug info is
available to the debugger.

I just tried xeyes on Weston master and it works here, but that doesn't
say much because Weston, Xwayland, and the X11 app all run
asynchronously, so one of us might just be getting lucky.

I'm afraid you have to debug this yourself. 'weston-debug xwm-wm-x11'
might prove useful, needs to be used with 'weston --debug'. Of course,
all the usual Valgrind, ASan etc. might be useful too, assuming you can
use them on a platform where you can reproduce the issue.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20200206/1882eca5/attachment-0001.sig>

More information about the wayland-devel mailing list