[ANNOUNCE] libinput 1.17.901

Peter Hutterer peter.hutterer at who-t.net
Wed May 26 03:29:34 UTC 2021

libinput 1.18 RC1 is now available.

No big new features, just general fixes and polishing everywhere. This is
mostly just flushing the main branch out. I don't expect the need for a
second RC.

Some of the user-visibile changes are:
- Gestures' unaccelerated motion now matches the accelerated motion (without
  accel, obviously). A bug caused these to be in different scales which
  didn't work overly well for obvious reasons.
- Better gesture detection should reduce the amount of pinch gestures
  detected as two-finger scrolling.
- Pressing the wheel button down now suppresses accidental scroll wheel
- Reworked clickpad detection means we should be more robust for devices
  with broken firmware.

As usual, please see the git shortlog for details.

Alexander Mikhaylenko (1):
      gestures: Filter unaccelerated deltas for gestures

Ben Weston (1):
      quirk: fix sensitivity for Dell Latitude 7490 pointing-stick

Chris Dickson (1):
      quirks: mark the 0x252 razer keyboard as internal

Greg V (4):
      quirks: recognize SPI bus
      quirks: add quirks for Apple SPI input devices
      quirks: implement DMI support on FreeBSD
      quirks: add wildcard to HID-over-I2C names (for FreeBSD)

Hans Gaiser (1):
      Add quirk for Lenovo Legion 5 Pro.

Jonas Ådahl (1):
      tablet-pad-leds: Open led file with O_NONBLOCK | O_CLOEXEC

JoseExposito (9):
      fallback: replace fallback_dispatch->wheel with an anonymous struct
      fallback: disable mouse scroll wheel while middle button is pressed
      tools/code-formatting: Add EditorConfig file
      touchpad/clickfinger: limit middle click to 3 fingers
      libinput: change gesture notify cancel parameter from int to bool
      gestures: rename int filter_motion to bool ignore_motion
      gestures: move the code to get raw pointer motion to its own function
      gestures: move up some functions to use them later
      gestures: move the logic to detect gestures to its own function

José Expósito (1):
      test: cleanup: remove fallthrough followed by break

Konstantin Kharlamov (2):
      util-list.h: simplify code by removing an excess initialization
      treewide: get rid of `tmp` argument in list_for_each_safe

Nicolas Fella (1):
      doc/user: Add instructions for using with CMake

Pedro Ribeiro (1):
      Add Lenovo Legion 5 keyboard to 50-system-lenovo.quirks

Peter Hutterer (55):
      completion: add missing libinput analyze subtools to the zsh completions
      tools/per-slot-delta: print the button state too while analyzing
      tools/per-slot-delta: handle KeyboardInterrupts nicely
      util: document our list interface
      tools/debug-gui: start the unaccelerated motion deltas in the screen center
      tools/debug-gui: move the pointer position into a struct point
      tools/debug-gui: move the abs pointer position into a struct point
      tools/debug-gui: draw a sprite for the unaccelerated pointer as well
      test: fix two inadvertent pointer jumps in a test
      test: add a comment to the thumb speed test
      touchpad: always push a touch's current point to the motion history
      test: localize a few variables
      test: update a few tests for more modern helpers
      filter: correct comments about the threshold's unit
      doc/user: explain why we are doing motion normalization
      test: fix debugging messages for gesture begin event
      test: simplify the helper for moving three touches at the same time
      test: push/pop event frames around three-touch movements
      tests: add a gesture test to ensure our unaccel deltas are in a sane range
      tools/record: factor out the output file collection
      tools/record: de-duplicate an error message
      tools/record: localize a variable
      tools/record: free the namelist when we're done
      tools/record: deduplicate the device opening logic
      tools/record: switch the output file from an fd to a FILE*
      tools/record: mark the iprintf function as printf
      tools/record: get rid of indent push/pop, replace with fixed indents
      tools/record: append the devices in-order
      tools/record: remember the first device in the context
      tools/record: rename the output file handling
      tools/record: rework the event printing
      tools/record: line up the "neutral state" message
      evdev: don't check the event time if it's higher than the dispatch time
      evdev: don't truncate event time to 32 bits
      quirks: add palm size quirk for the Gigabyte Aero 15
      touchpad: factor out clickpad assignment to a helper
      touchpad: use some helper variables to make the code easier to read
      touchpad: a touchpad with only one button is a clickpad
      touchpad: if we have a right button, let's assume it's not a clickpad
      gitlab CI: switch to Ubuntu 21.04
      doc/user: fix a link to the system hwdb file
      Change various references to the master branch to main
      tools/record: fix a strlen assumption
      tools/record: print the HID report descriptor as hex
      tools/record: linebreak the hid report descriptor every 16 bytes
      meson.build: bump to 1.17.900
      tools/record: add support for hidraw recording
      gitlab CI: bump from Fedora 32 to 34
      editorconfig: add settings for python files
      gitlab CI: add a JUnit XML report for scan-build
      tools/replay: do not replay key repeat events
      tools/record: narrow down the obfuscation range
      doc/user: #wayland is now on oftc
      gitlab CI: use FDO_CI_CONCURRENT in our meson build script
      libinput 1.17.901

Udo Rader (1):
      quirks: add quirk for Lenovo Yoga Slim 9 Touchpad

dan g (1):
      quirks: add palm rejection support for all Razer Blade models

novenary (3):
      Improve disambiguation between two-finger pinch and scroll
      Allow reviving a thumb that moves sufficiently
      Increase pinch grace period to 300ms

satrmb (1):
      evdev: restart debouncing timers after every event

weizhixiang (3):
      replace strncmp with strneq for safety-check
      use ARRAY_FOR_EACH when traverse array
      use more safety list_for_each_safe when remove element in traversing list

git tag: 1.17.901

SHA256: 09d735cb59a2077839adc4591398f2de7ea72022e22fd4f6eab4bb1e50b23095  libinput-1.17.901.tar.xz
SHA512: 7d6fa4377eea2714b3a26ec3a26618b22fc257a9811a1f17672ffc409f991d966bb36f4a9cd0619f6ac3e70585b980baabf87b3b388cbeb7e674926b5d83969c  libinput-1.17.901.tar.xz
PGP:  https://www.freedesktop.org/software/libinput/libinput-1.17.901.tar.xz.sig

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/wayland-devel/attachments/20210526/f5881831/attachment.sig>

More information about the wayland-devel mailing list