[Xcb] XCBImage

Jamey Sharp jamey at minilop.net
Mon Mar 14 10:28:26 PST 2005

On Mon, Mar 14, 2005 at 07:03:26PM +0100, Vincent Torri wrote:
> Hello,

Hi Vincent!

> just a question: before doing more test, i would like to fix a bit the
> api, in particular the naming convention of the functions.

Heh. Alright. APIs are hard.

> do you prefer:
> 1) a name with properties separated by underscores, or not ?
> (xcb_image_put)
> 2) Properties with first "big" letter or not ? (XCBImagePut or
> XCBimageput)
> 3) the "action" at the end or not ? (XCBImagePut or XCBPutImage)
> 4) something else ?

I guess this ought to be consistent with XCB, which was kind of
following Xlib conventions of "camel caps" (XCBFooBarBaz).

As for word order... uh... well, I dunno, but every public function in
the XCBImage library should have a name starting with XCBImage, and I
guess XCBImagePutImage would be kind of silly, so I guess it should be
XCBImagePut. (And maybe XCBImageSHMPut?)

> my aim is to test the image stuff with the ZPixmap format (with and
> without shm support) and to begin as soon as possible the xcb port of
> evas.

Sounds fun.

Have you had a chance to look over my changes to XCBImage? I think if
you look at get_pixel_generic and put_pixel_generic you'll know about as
much as I do about how XYPixmap image formats work.


More information about the xcb mailing list