[Xcb] XCB naming conventions

Ian Osgood iano at quirkster.com
Wed Sep 13 14:13:36 PDT 2006

---------- Original Message ----------------------------------
From: Jamey Sharp <jamey at minilop.net>
Date:  Wed, 13 Sep 2006 12:04:53 -0700

> Thoughts on CARD8 etc.? It would be good if we were using a different 
> name than Xlib uses: the current hack to make that work is painful. 

I'm fine with the C99 type names, and the underlining naming convention in 
general. I also like expanding the Req/Rep contractions to full words. This is the 
right time to make the change.

Also, we currently have three aliases for a byte: CARD8, BYTE, and BOOL. I propose 
dropping BYTE, and naming the others uint8_t and bool8_t. (Having a separate 
boolean type conveys range information, and the name distinguishes it from other 
boolean types whose size is incompatible or undefined.)


More information about the Xcb mailing list