[Xcb] XCB naming conventions (progress)

Vincent Torri vtorri at univ-evry.fr
Sat Sep 16 02:49:41 PDT 2006


so, xproto.h is almost correctly generated, now. There is some problems 
and remarks that I want to discuss here.


1) XCBBUTTON struct type and XCBButton enum type have the same name with 
underscores (xcb_button_t). I think that we should rename XCBButton. Any 
Idea for that ? In X.h, it's described as button names. So maybe the 
protocol description should be changed in XCBButtonName.

2) same problem with XCBHOST and XCBHost. Although I don't have an idea 
for the enum name. X.h does not describe it well.

3) I have a technical problem with XSLT : some requests ask for pointer 
and its length. I automatically add '_t' to the name of the type, but 
there is a problem in case the type is char and void. The xsl code is :

       <xsl:attribute name="type">
         <xsl:text>const </xsl:text>
         <xsl:call-template name="canonical-type-name" />
         <xsl:text>_t *</xsl:text>

So I would like to test the value returned by the template and add if only 
if the value of canonical-type-name is different from char and void

Does someone have an idea on how to do that ?


1) in xproto.xml, there is the structure SetupReq. Shouldn't iit be 
renamed as SetupRequest ?

2) for enum dans define values, I use upper case letter, with words 
separated with underscores. Is it ok for everybody ?

I think that's enough for now.

thank you


More information about the Xcb mailing list