[Xcb] naming convention (finished)

Ian Osgood iano at quirkster.com
Sun Sep 17 16:07:52 PDT 2006

On Sep 17, 2006, at 3:05 PM, Vincent Torri wrote:
> On Sun, 17 Sep 2006, Ian Osgood wrote:
>>> 7) I've also changed the naming convention of the xcb api. I  
>>> think that it's better to have a consistent scheme.

I also noticed XCBSetupGeneric in xcb_conn.c.

>> Symbols mentioned in the comments also need to be converted.
> which ones ?

Mostly the doxygen comments in xcb.h. Example: comment for XCB_NONE  
still says "XCBNone".

There are various camel case references in comments throughout the code.

> As I'm changing the files, I can also clean up a bit the files.  
> Adding some new lines, and doing some indentation, like :
> If nobody is against it, I can do that.
> Vincent

I'd prefer doing formatting as a separate commit.


More information about the Xcb mailing list