[Xcb] naming convention (finished)

Ian Osgood iano at quirkster.com
Mon Sep 18 08:34:07 PDT 2006

On Sep 18, 2006, at 6:07 AM, Jeremy A. Kolb wrote:

> On Sun, 17 Sep 2006, Ian Osgood wrote:
>> What does everyone else think about switching the prefix from "xcb_"
>> to simply "x_" as Bernardo suggested?
> I prefer "xcb_" because it tells people what lib it is.  I think "x_"
> could confuse people later on when there's more of a transition stage.
> "xcb_" is also more in tune with "gtk_", "ecore_", "cairo_" etc.

I like that argument. Also "xcb_" is easier to search for.

Another idea: keep the "xcb_" prefix for the static API, and use "x_"  
for interfaces generated from the protocol files.


More information about the Xcb mailing list