[Xcb] using enums as type in sync.xml

Thomas Hunger hto at arcor.de
Thu Sep 6 09:07:39 PDT 2007

> Comments:
>  > +  <enum name="ALARMSTATE_ENUM">
> I don't like this naming convention.

Agreed, it is ugly. 

Maybe we could just annotate the enum?

    <enum represenation="CARD32">

I believe we need to use a CARD32 instead of size="4" so that 
byte-swapping is correct when someone implements server side xcb.


More information about the Xcb mailing list