[Xcb] Should we use <bit> instead of <value>?

Peter Harris peter.harris at hummingbird.com
Mon Jan 7 12:37:30 PST 2008

Peter Harris wrote:
> Ian Osgood wrote:
>>  (Naming: I prefer  
>> not to include "Mask" in enumeration names, because it comes out  
>> duplicated, for example  "XCB_EV_MASK_NO_EVENT_MASK". Don't worry  
>> about compatibility; no one is using these extensions yet.)
> I agree, but that's a different patch.

I've just sent a two patch series to the XCB list for review.

[Xcb] [PATCH 1/2] Remove redundant "Mask" label
[Xcb] [PATCH 2/2] Remove more Mask labels.

What are your thoughts? Are these what you intended?

Note specifically that these don't touch XCB_EV_MASK_NO_EVENT_MASK 
(since the EVENT_MASK referred to in the EV_MASK is a separate mask 
entirely, so that particular label is not as redundant as it first appears).

  Peter Harris

More information about the Xcb mailing list