[Xcb] Tiny cleanup patch that removes some code duplication
Henning Sten
henning.sten at yahoo.com
Sat Sep 13 13:52:01 PDT 2008
Hi Julien et al,
I'm sort of new to the xcb code. Can you maybe explain what kind of work arnaud is doing on his xcb-utils branch? Also, how does it impact/obsolete my cleanup patch?
While I'm posting, I also have two other questions:
1) I've introduced a utility function "get_atom" in both flames and julia demos, maybe there should be a synchronous helper function like that added to xcb-utils or somewhere (for use in non-perf critical paths only ofc)??
2) Also, I've seen code like this on several places (see below). In this context, why is 0x7f used? Is there a constant for this instead or maybe the API could be made a little bit clear/readable?
if ((e = xcb_poll_for_event (f->xcb.c)))
{
switch (e->response_type & 0x7f)
Thanks,
HS
--- On Sat, 9/13/08, Julien Danjou <julien at danjou.info> wrote:
> From: Julien Danjou <julien at danjou.info>
> Subject: Re: [Xcb] Tiny cleanup patch that removes some code duplication
> To: "Henning Sten" <henning.sten at yahoo.com>
> Cc: xcb at lists.freedesktop.org
> Date: Saturday, September 13, 2008, 5:50 PM
> At 1221318549 time_t, Henning Sten wrote:
> > This is a tiny cleanup patch that removes two similar
> blocks of code and replaces them with calls to an existing
> function.
>
> Unfortunately I guess this won't be applicable with
> recent Arnaud's
> patches.
>
> --
> Julien Danjou
> // ᐰ <julien at danjou.info>
> http://julien.danjou.info
> // 9A0D 5FD9 EB42 22F6 8974 C95C A462 B51E C2FE E5CD
More information about the Xcb
mailing list