[Xcb] RFC: Altenum updates for xcb/proto

Barton C Massey bart at cs.pdx.edu
Wed Feb 25 00:54:25 PST 2009

I'm confused what we're trying to name?

The only constraint I have on generated names, that I'm
pretty religious about, is that any generated name should be
inferrable from the protocol specification without reference
to other documentation or source code.  In this case, does
this mean something like XCB_WINDOW_NONE?


In message <49A2F5EE.7020409 at opentext.com> you wrote:
> Julien Danjou wrote:
> > At 1235075347 time_t, Peter Harris wrote:
> >> Suggestions for a better name are particularly welcome.
> > 
> > AnyValue?
> > 
> > That's a suggestion. :)
> The fundamental dilemma I'm having is the rift between an enum name that
> is descriptive when reading the XML ("MayBeNone" vs "AnyValue" or
> "Untyped") and an enum name that doesn't look ugly once libxcb is done
> On the basis that generated bindings are (hopefully) used a lot more
> often than the .xml files are read by humans, I'm starting to lean
> toward "Untyped".
> In the hope that I'm missing something obvious that will make both the
> xml and the generated bindings beautiful, I'm going to ask again: Can
> anyone think of a better name? Please?
> Thanks,
>  Peter Harris
> -- 
>                Open Text Connectivity Solutions Group
> Peter Harris                    http://www.opentext.com/connectivity
> Research and Development        Phone: +1 905 762 6001
> pharris at opentext.com            Toll Free: 1 877 359 4866
> _______________________________________________
> Xcb mailing list
> Xcb at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xcb

More information about the Xcb mailing list