[Xcb] [Bug 28595] xcb_io.c: record extension is broken

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Jun 19 10:59:58 PDT 2010


--- Comment #3 from Josh Triplett <josh at freedesktop.org> 2010-06-19 10:59:57 PDT ---
Jamey and I fixed this in commit c115095d7f2bc4f5a4fb26380e3698fefdad7611. 
Turned out we had a bug in the async-reply handling in poll_for_response. 
Nobody noticed until someone tried to use async replies, like RECORD does. :)

The commit message:

    poll_for_response: Really handle xcb_poll_for_reply getting a reply.

    Don't lose async replies. That's bad.

    `xlsfonts -l`, which uses XListFontsWithInfo, worked fine, because the
    _XReply path worked; that path waited for replies, rather than polling.

    However, XRecordProcessReplies, which does nothing but call XPending,
    relied on the event-handling path to process async replies, and that was

    Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=28595

    Signed-off-by: Jamey Sharp <jamey at minilop.net>
    Signed-off-by: Josh Triplett <josh at joshtriplett.org>

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the Xcb mailing list