[Xcb] Some autogenerated docs questions...

Josh Triplett josh at joshtriplett.org
Wed Jun 23 21:16:16 PDT 2010

On Wed, Jun 23, 2010 at 08:42:02PM -0700, Jamey Sharp wrote:
> On Tue, Jun 22, 2010 at 2:33 PM, Ulrich Eckhardt <doomster at knuut.de> wrote:
> > Third thing is the include guards. These are currently like "__RES_H". In this
> > case, the name is unfortunately generic. Further, any macro or identifier
> > containing two consecutive underscores is reserved to the compiler. I'd use
> > something starting with XCB, like XCB_<name>_HEADER_INCLUDE_GUARD. This is
> > long enough to make any collisions very unlikely and more portable.
> We discussed this recently on the list, and consensus was that yeah,
> somebody should fix that. Perhaps that somebody is you?

I wouldn't suggest going as verbose as _HEADER_INCLUDE_GUARD; XCB_RES_H
or similar should probably suffice.  (The bikeshed should be *blue*,
darnit. :) )

- Josh Triplett

More information about the Xcb mailing list