[Xcb] XCB documentation effort

Josh Triplett josh at joshtriplett.org
Fri Nov 25 18:26:23 PST 2011

On Thu, Nov 24, 2011 at 11:43:01PM +0000, Michael Stapelberg wrote:
> Excerpts from Peter Harris's message of 2011-11-24 23:36:54 +0000:
> > The names in function parameters are documentation only. Changing the
> > names affects neither API nor ABI AFAIK, so the change should be okay. I
> > think I'd be a smidgen happier if the man pages match the .h files, but
> > I can't bring myself to care all that much.
> OK, so I’ll use 'conn' in the documentation. To make you happy, I am also
> willing to change it in the C generator (separate patch of course). Do you
> agree? :)

You should definitely keep the code generator and the
documentation consistent on naming.  I don't have a strong opinion on
the variable names; "conn" and "reply" sound fine to me.

- Josh Triplett

More information about the Xcb mailing list