[Xcb] Problems with xcb in a vnc session

Jay Cralley Jay.Cralley at mathworks.com
Tue Jan 14 06:35:32 PST 2014

Hi All,

I have a sample program that uses XCB to get the _XKB_RULES_NAMES property. This program seems to work when I run it from my physical display, but not when I run it in a vnc viewer. I originally thought that the problem was that our vncserver version (xvnc4server, version 4.1.1) does not support the XKEYBOARD extension. So I installed realvnc-vnc-server (version 5.1.0), which does support XKEYBAORD, but the program still fails in the vnc viewer. I have attached the program. When run in a vnc session, it seems to fail on the xcb_get_property_reply() call. The struct it returns has a value length of 0 and non-zero bits in the padding. The error pointer that I pass in remains NULL, so it doesn't appear that xcb registered an error.

Can anyone tell me why it won't work for me in vnc? I am running Debian 6 64-bit.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/xcb/attachments/20140114/a579df29/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xcbprog.c
URL: <http://lists.freedesktop.org/archives/xcb/attachments/20140114/a579df29/attachment.c>

More information about the Xcb mailing list