[Xcb] Problems with xcb in a vnc session

Ran Benita ran234 at gmail.com
Tue Jan 14 09:58:40 PST 2014

On Tue, Jan 14, 2014 at 05:18:06PM +0000, Jay Cralley wrote:
> Hi Ran,
> Thanks for your reply. When I try running "setxkbmap us" in the vnc viewer, I get the following:
> Couldn't interpret _XKB_RULES_NAMES property
> Use defaults: rules - 'xorg' model - 'pc105' layout - 'us'
> Error loading new keyboard description
> So it looks like setxkbmap has the same issue. I also tried starting vncserver with the -xkbmap switch set to "us". This did not help.

This means that the property indeed isn't set. I can't blame them; I
mean, it's not in any standard that I know of.
The VNC product you mentioned isn't open source, so I can't look at
their code. But perhaps you're in a position to influence them to set
it (not very helpful I know).

Alternatively, you can set the property yourself. The libxkbfile library
has a function for that, XkbRF_SetNamesProp:
But you can do the equivalent with xcb by modifying your program a bit.
(I tried using xprop -set, but couldn't get it to work).

> The reason I am doing this is because we use Qt heavily and want to upgrade to version 5.*, but they have switched to using xcb for their x11 bindings. I wrote the sample program to eliminate Qt's code as the problem. Right now I would be happy with any way to work around the issue. I am a bit out of my field of expertise, so I am not sure how much of their code I would need to change to go directly for the XKB APIs. Can you give me a nudge in the right direction?

See: https://bugreports.qt-project.org/browse/QTBUG-32760
Haven't read in detail...

Incidentally, I'm just about to send some patches that will hopefully
help qt solve the root cause of these problems (guess I'll send to this
list). But this is not an immediate solution.

More information about the Xcb mailing list